Issues with UPS Label Generation
Incident Report for Ordoro
Resolved
The issues we were experiencing have been successfully resolved. UPS is now fully operational and available for your use.

We appreciate your patience and understanding while our team worked to fix this problem. Please reach out if you have any questions.
Posted Jan 25, 2024 - 14:51 CST
Update
Our developers are continuing to work on this issue. We hope to return UPS shipping to normal as soon as possible. More updates to come!
Posted Jan 25, 2024 - 12:52 CST
Investigating
We are currently experiencing some technical difficulties with UPS label generation feature. Our team is actively working to resolve this issue as quickly as possible. During this time, the service for generating UPS labels may be temporarily unavailable.

We apologize for any inconvenience this may cause and appreciate your patience while we address this problem.
Posted Jan 25, 2024 - 11:21 CST
This incident affected: Ordoro.