Issues with Address Validation
Incident Report for Ordoro
Resolved
The address validation issue has been successfully resolved. Our team has rerun the validation process, and everything is now working as expected.

Thank you for your patience during this period. Should you encounter any further concerns, please don't hesitate to reach out.
Posted Jul 26, 2023 - 10:59 CDT
Monitoring
We're seeing improvements with address validation. Our team is closely monitoring the situation to ensure everything functions as expected. Stay tuned for further updates.
Posted Jul 26, 2023 - 09:57 CDT
Investigating
We're aware of some difficulties with address validation. Our team is actively investigating to identify the root cause and implement a prompt resolution.

We apologize for any inconvenience, and we'll keep you informed of any developments.
Posted Jul 26, 2023 - 08:39 CDT
This incident affected: Ordoro.