Shipping Label Issue
Incident Report for Ordoro
Resolved
Good news! Our developers have successfully resolved the issue. We appreciate your patience and understanding during this time.
Posted Oct 16, 2023 - 14:27 CDT
Investigating
We're currently experiencing some lag and intermittent timeouts when creating shipping labels. Our team is urgently investigating the issue.

We understand the inconvenience this may cause and appreciate your patience. We'll provide further details and updates as soon as they're available.
Posted Oct 16, 2023 - 13:54 CDT
This incident affected: Ordoro.