AWS Outage Impacting Label Creation

Incident Report for Ordoro

Resolved

Pitney Bowes has resolved the issues on their side. We’ve tested, and USPS shipping via Pitney Bowes is now working as expected.

You may need to refresh the rates on your orders before shipping. If you have any questions, please contact our Support team.
Posted Oct 20, 2025 - 15:54 CDT

Update

Most carriers are back online. USPS via Pitney Bowes is still affected. See the Pitney Bowes status page for updates. https://status.pitneybowes.com/
Posted Oct 20, 2025 - 14:38 CDT

Monitoring

Due to ongoing AWS outages, some users may experience errors when creating shipping labels. Our team is monitoring the situation and will post updates as they become available.
Posted Oct 20, 2025 - 11:59 CDT
This incident affected: Ordoro.