FedEx Server Error

Incident Report for Ordoro

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 12:40 CDT

Investigating

FedEx is having an issue that is impacting some Ordoro users. Shipping rates and the ability to create labels are impacted and you may see this error: INTERNAL.SERVER.ERROR: The request failed due to some unknown reason.
Posted Jul 14, 2025 - 11:56 CDT