Loading Delays with Shipping Labels
Incident Report for Ordoro
Resolved
Good news! Both USPS and UPS are now operating at their usual, quick speed.

UPS experienced some downtime which was the root problem. For more details, visit the UPS status page https://www.ups.com/api-status?loc=en_US

Thank you for your patience while we monitored and addressed this issue.
Posted Nov 29, 2023 - 12:54 CST
Investigating
We're currently experiencing longer loading times for creating shipping labels, particularly with USPS and UPS. This might cause timeout errors or unavailable service messages.

Our team is working on fixing this ASAP. We'll update you as soon as we have more info. Thank you for your patience!
Posted Nov 29, 2023 - 12:12 CST
This incident affected: Ordoro.