Infrastructure Issues

Incident Report for Ordoro

Resolved

The issue has been fully resolved and all services are now operating normally. Order imports and other functionality is back.

Thanks for your patience while we monitored this outage.
Posted Jun 12, 2025 - 16:55 CDT

Monitoring

Response times are recovering, and affected services are beginning to stabilize. Orders should start appearing in your accounts shortly.

Our engineers are closely monitoring the situation and will provide further updates as they become available. Thanks again for your patience.
Posted Jun 12, 2025 - 16:03 CDT

Identified

We’re currently experiencing platform-wide issues due to a widespread outage with Google Cloud Platform (GCP), which is also impacting many other sites and services across the internet. You can follow their incident here: https://status.cloud.google.com.

Our team is closely monitoring the situation and will post updates here as new information becomes available.
Posted Jun 12, 2025 - 15:38 CDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 13:39 CDT

Investigating

We're investigating a platform issue that may cause delays with order imports and slow Analytics performance. Our team is actively investigating the problem and working to restore full service as quickly as possible.

We'll continue to share updates here as we learn more. Thanks for your patience and understanding.
Posted Jun 12, 2025 - 13:34 CDT
This incident affected: Ordoro.