UPS Service Disruption
Incident Report for Ordoro
Resolved
UPS has resolved the problem and we're able to fetch rates in Ordoro again. Please reach out to support@ordoro.com if you have any questions. Thank you for your patience.
Posted Jul 25, 2024 - 13:57 CDT
Identified
Due to a technical problem on UPS's end, creating UPS shipping labels through Ordoro is not currently possible.

We are actively monitoring the situation. Rest assured, we will share updates as soon as they are available. Thank you for your patience and understanding while UPS works to resolve this issue.
Posted Jul 25, 2024 - 12:15 CDT
This incident affected: Ordoro.