Issues with USPS Label Creation
Incident Report for Ordoro
Resolved
Good news! Our monitoring confirms that the issues with Pitney Bowes have been fully resolved. All services, including USPS rate and label creation, are back to normal.

Thank you for your patience. If you experience any further issues, please let us know.
Posted Nov 28, 2023 - 12:11 CST
Update
Pitney Bowes recently announced their errors have stopped. See the info here - https://apistatus.pitneybowes.com/ We're actively monitoring the situation to ensure everything is running smoothly.

Additionally, we're receiving intermittent reports that USPS rates and labels are accessible again.

We encourage you to try creating USPS labels again. If you encounter any further errors or issues, please don't hesitate to reach out.
Posted Nov 28, 2023 - 11:31 CST
Monitoring
Our USPS provider, Pitney Bowes, is currently experiencing service disruptions. For detailed information, you can visit their status page directly here - https://apistatus.pitneybowes.com/.

We are closely monitoring the situation and will provide updates as soon as they become available. Our team is committed to keeping you informed and working towards minimizing any impact on our services.
Posted Nov 28, 2023 - 11:11 CST
Update
We are continuing to investigate this issue.
Posted Nov 28, 2023 - 11:02 CST
Investigating
We're currently experiencing issues with USPS label creation. Our developers are urgently addressing this and are committed to resolving it as soon as possible.

We don't have an ETA yet, but updates will be provided here when available. We appreciate your patience and understanding as we work through this.
Posted Nov 28, 2023 - 11:01 CST
This incident affected: Ordoro.