Issues creating shipping labels for RMAs

Incident Report for Ordoro

Resolved

This issue has been resolved. Shipping labels can be created for RMAs again.

We appreciate your patience while our team addressed this issue.
Posted May 06, 2026 - 08:29 CDT

Investigating

We are currently investigating an issue preventing shipping labels from being created for RMAs (Return Merchandise Authorizations).

Customers may see a blank white page or error message when attempting to create an RMA shipping label.

Our team is actively working on a fix, and we’ll share updates here as we learn more.

We apologize for the disruption and appreciate your patience.
Posted May 06, 2026 - 07:30 CDT
This incident affected: Ordoro.