USPS Endicia is having issues - rates and labels are slow in Ordoro
Incident Report for Ordoro
Resolved
USPS Endicia has resolved the issues on their side. We've monitored to ensure everything looks good on our side. We don't see any errors so considering this resolved. Thank you very much.
Posted Oct 08, 2019 - 15:47 CDT
Update
Endicia resolved the earlier issue but is now experiencing 502 Gateway errors. See their status page updates here - https://status.endicia.com/incidents/9jksxgyb87xq.

From Endicia:

"Endicia is currently experiencing a technical issue that we are working to resolve. Our engineering team is working to resolve this issue as quickly as possible. We'll share another update shortly."
Posted Oct 08, 2019 - 13:50 CDT
Identified
USPS Endicia has posted about issues their system is having as of 8:30am CDT. See their status page updates here - https://status.endicia.com/incidents/r674rdqvhmx5.

These issues are showing up in Ordoro by USPS rates not loading or moving very slowly for Endicia shipping labels. See Endicia's status below.

"Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we'll have a solution for this soon!"

The Ordoro team is monitoring this closely and will post updates as they're available.
Posted Oct 08, 2019 - 11:32 CDT
This incident affected: Ordoro.