Endicia USPS rates and labels not printing
Incident Report for Ordoro
Resolved
Endicia has resolved the behavior and shipping rates are now pulling into Ordoro again. Thank you for your patience as Endicia quickly resolved this behavior.
Posted May 13, 2019 - 14:45 CDT
Investigating
We received reports of rates not loading for USPS Endicia shipping labels. Endicia has acknowledged the issue on their status page (status.endicia.com). See Endicia's status below.

"Investigating - Endicia Engineers have identified an issue that may temporarily affect some of our customers' ability to print postage and shipping labels. Sorry for the inconvenience – we'll have a solution for this soon!"

We're monitoring this closely and will post further updates as it's available.
Posted May 13, 2019 - 14:38 CDT