Cannot create USPS Pitney Bowes labels
Incident Report for Ordoro
Resolved
USPS Pitney Bowes has resolved the issue on their end with no further error for the last 20 minutes.

USPS label creation is running smoothly again. Please reach out to support@ordoro.com if you need further assistance. Thank you!
Posted Sep 17, 2021 - 16:25 CDT
Identified
For USPS Pitney Bowes, you may see errors when fetching rates or creating a label.

They are actively working on this issue. See Pitney Bowes' status page - https://apistatus.pitneybowes.com/incidents/5zqpgz6d7rfg.

We will post additional details as they are available.
Posted Sep 17, 2021 - 15:55 CDT
This incident affected: Ordoro.